Google Cloud is experiencing an issue blocking some application functionality.

Incident Report for CaliberMind

Resolved

US customers are showing signs of recovery.

Google is reporting that full recovery is expected within the hour.
Posted Jun 12, 2025 - 15:24 MDT

Monitoring

Google has identified the issue and is rolling out a fix.

At this time, CaliberMind customers in the EU appear fully recovered.

We are continuing to monitor progress with US customers.
Posted Jun 12, 2025 - 14:36 MDT

Investigating

We are currently investigating this issue.
Posted Jun 12, 2025 - 12:14 MDT
This incident affected: Salesforce Flows, CM Pipeline, and Insights Reporting.