Partial Dashboard Outage

Incident Report for CaliberMind

Postmortem

Around 11:30AM PDT, customers with data in the US multi-region began experiencing performance degradation, failed queries, or delays with respect to BigQuery services due to an incident in Google Cloud.

User Impact

  • Elevated Latency: BigQuery jobs and queries were taking significantly longer to complete than normal.
  • Job Timeouts: Queries sometimes failed entirely and returned timeout errors.

Around 1:00PM PDT, the issues appeared to be resolved.

Posted Apr 14, 2026 - 15:35 MDT

Resolved

This incident has been resolved, we are researching the cause and will provide that when it becomes available.
Posted Apr 14, 2026 - 14:21 MDT

Investigating

Some customers are experiencing issues loading dashboards. We're actively investigating.
Posted Apr 14, 2026 - 13:35 MDT
This incident affected: Dashboard UI.