All connectivity issues related to this incident have been resolved by our service partner.
Posted Nov 18, 2025 - 07:38 MST
Monitoring
A fix has been implemented by our service partner and they are working to restore services.
Posted Nov 18, 2025 - 06:48 MST
Update
CaliberMind seems to be affected by an outage at one of our service partners. We're working closely with our partner to restore full service as soon as possible. Thank you for your patience.
Posted Nov 18, 2025 - 06:42 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 18, 2025 - 06:41 MST
Investigating
Some users are experiencing issues accessing CaliberMind web resources due to an issue with one of our service partners.
Posted Nov 18, 2025 - 06:41 MST
This incident affected: Dashboard UI, Salesforce Flows, CM Pipeline, and Insights Reporting.